Files not loading on Nextcloud app

Anyone having their files not displaying on their Android app but they will display on the browser interface?

Other users on my / our nextcloud can access their files on their android devices and I can log in as them on my device and view their files. So now I don’t know if it’s an app issue or an issue with my account?

Full disclosure… Other users on my nextcloud have a max of 100 gig of data on Nextcloud. I have 500 gig… But that shouldn’t make a difference right? After all it’s just displaying a folder tree and not directly accessing each file?

Any ideas or thoughts would be great thanks…

Strange, can you reinstall mobile app to see if that helps?

Uninstalled and reinstalled twice… Thought it was my device until I logged in on 2 other user accounts and they worked perfectly…

Just logged into my account on someone else’s device and it’s not displaying… At least that rules out my device I hope…

By device you mean a phone I guess.

Can you open your Nextcloud account in a incognito mode and see if files are actually visible and not just cached in the browser in some form.

Sorry yes device = android phone

Folders all display correctly on a browser such as edge or chrome… It’s the Nextcloud android app where my folders won’t display…

Hence not sure if it’s an account / user / software issue or an app issue?

Yes, that is what I am trying to understand.
You cannot see files in android no matter what phone you use.
You can see files in a browser, is it one browser on one PC or any PC any browser still shows your files, incognito on/off. You need to try these things as maybe you can see files only in one browser on one PC, that would explain something.

Hi, just tried on a different laptop in edge in normal and Private and files showed up on both. It’s a laptop I have never used for my login before, so know it’s not showing cached files…

Can you try forcing the file scan for your user to see if that gives any error or changes the mobile app behaviour:

snap run nextcloud.occ files:scan [user]

Where [user] is your user name.

Well I appear to be a complete plonker… Not being a programmer I looked back and found that I needed a ssh client to enter the code on… Found that Putty is the recommended client… I have used a client in the past (can’t remember if is was putty…) with some direction so I thought I could work it out… Downloaded said client, found ip on my login page. now this is where things go bad… ’ * Login: root (always)’ 0 so my username is root? If this is the case the password should be syncloud? or does it become the password I use to log into syncloud? Reason I ask is nothing appears to be working… Where do I go with this? And is there somewhere within the syncloud file structure I can go and find the password or a way of extracting it using the file app for instance? I realise this might be a pm moment as it might not be the best thing to discuss something like this on an open forum…

Sorry the instruction you are talking is this: SSH · syncloud/platform Wiki · GitHub

I really thought it is clear, but I can fix it.

Login: root (always)

Password: syncloud (becomes your device password when activated)

When you activate the device you set the main user password it becomes SSH “root” user password.

Thanks Boris. So I’m not such a plonker as I was typing the right info in… Did it a dozen or more times and then for no reason it worked and I got in!

So I ran the command and below are 2 outcomes.

The first directly below is the result for my username


The one directly below is for another user just to have tried to see if I got a different result!


So according to this I have no files or folders but the other user has a few! lol

The below information disagrees! lol


Ok, so I think there may have been a user issue brewing… I now cannot log into my nextcloud … I also don’t appear to be able to log into syncloud either…


Bit of a worry…

If I gain access in using an ip address and go to the users app. It asks me to log in … And when I do it then asks me to change my password. And of course once that’s done it won’t let me into the user area… It’s all going terribly well! lol

Users app asked you to change the password? (Have not seen it doing that)
Can you login anywhere now device web or ssh?

Password is now in a loop and I can’t log in on the app or online… Last time I tried I couldn’t log into my syncloud login. The workaround being using the ip address. Other users all k. It’s just me and I’m the admin typically! Ssh still working last time I tried… Will have a go after work and see what happens…

Quick update.

I can log into on my pc… (
Also using my pc I cannot then log into my domain address, internal address or external address. using the links on the syncloud user homepage… I get the LDAP Result Code 49 “Invalid Credentials”:

Using the syncloud app I do have access but the users app won’t lt me log in and also I don’t have access to nextcloud on my account but the other users do!

I’m hoping there are some simple fixes for these issues?

if you can login using ssh you can reset the device credentials but it will remove all users and you will need to create them again (same usernames should be fine).

That makes sense… delete the file, reactivate the system to gain access and create a usable password and re-ad the users… One problem… I have not got the faintest idea how to delete the file? I’ve done all sort of searching but can’t find any commands or hints? I realise that I am clueless… When I embarked on this journey with Syncloud I didn’t quite envisage needing to know this stuff. lol Help Please!

Right, fixed the doc, it is:

rm /var/snap/platform/current/platform.db

so, put the line of code into putty… now my page is now showing red…


I still have access through putty but no access through my domain, int ip, ext ip or through the app.

Sorry to be needy but what on earth do I do now? Looks like I need to activate it but I don’t appear to have a way!?

Forget about site for now.

Do you know IP of your device (router can show it)?
Can you open your device IP in the browser?
If yes it will allow you to activate again(select the same domain name).

I guess you have removed the file name above on the device so device should go into ready to activate mode and show activation wizard on the web.