Nextcloud Version 627 - Folder structure no longer available

Hello together,

with the latest update to Version 627 of the Nextcloud App the folder structure for the users is no longer available with my setup. Logging in to the web module gives following error message “This directory is unavailable, please check the logs or contact the administrator”
Synchronization with the Nextcloud app is no longer possible.

Checking the drive and all the files are still where they belong.
Also the file access with a direct nextcloud link is possible.

I tried setting up the users again, no change.
Also using the Nextlcoud file scan with “snap run nextcloud.occ files:scan --all” did not change anything.

Anyone having the same issue?


On the web can you see all files?
On the web can you upload a file?

On Android app I think I saw some error after update but then after refreshing files in it started to upload files normally.

Are you talking about mobile or desktop app?

same problem here. In my case I started to upload a couple of files via windows client. At first everything seemed to be fine but then suddenly the upload stopped with the same error which d.mule described. After that I couldn’t see the files on the web anymore and the client stopped with an error…

@jangoetz is this for your main admin user you cannot see files on web?

What if you open incognito browser window?

Are you using external storage disk?
If you run this on server using SSH does this list your files?

ls /data/nextcloud/[user]/files

Where [user] is your login, you do not have to post it here.

If that shows files but you cannot see them on the web under the same account, can you run this SSH:

snap run nextcloud.occ files:scan --all

And tell me if it produces any error.

Also please send logs to support from Settings - Support and tell me exact time when you sent please.

Hello Boris,

thank you for your support!

On the web I see no files at “All files”
At “Recent” I see all files I have uploaded.
Android and also Linux client gives an error message.

I am using an Odroid HC1 with SSD installed.

“ls /data/nextcloud/[user]/files” shows all files
“snap run nextcloud.occ files:scan --all” runns wiht out an error and gives back that files were found

I have send the logs at 07:41 CET


At “Recent” I see all files I have uploaded.

Android and also Linux client gives an error message.

Could you refresh ctrl + f5 the web oage with the error few times and send logs right away again please?

Done, sent 13:48 CET

Now I’ve tried some of the things you told me, boris.

  • Yes, it is the admin user with which I can’t see the files.
  • An incognito browser window didn’t change anything.
  • I’m using an external USB-stick.
  • In my case the windows client showed the error and the files disappeared in the web, but I could see and open them before the error occurred.
  • I tried to upload my files in directly into the web. This worked for some files and folders but the the error occurred even there.
  • “ls /data/nextcloud/[user] /files” shows my folders
    -the second ssh operation didn’produce an error
  • one thing is different to d.mule. I cannot see all of my files and folders in the recent category in the web

I’ve sent my logs at 4:23pm cet

Just tried to reach my files from windows pc via webdav. I could see all files/folders and open/edit them…

Sorry I cannot see anything in the log sent to us still as it is full of pihole mesages (we need to reduce its logging level).
Could you send the output of this command to support email:

journalctl | grep nextcloud

Right after refreshing the error page few times to make sure logs capture the error.

My suspicion it has something to do with php 32 bit getting old.
I will try do do some experiments on my hc2.

@jangoetz you seem to have cleaner logs, can you try to open web or desktop client to see the error message and then send log from Settings - Support page?

Also do you see the original error still or now just files missing with no error message?

I’ve just sent the log 08:33 pm cet.
When I go to the files page in the web, I can still see the error message. In my case it is german but it says: “This directory is unavailable, please check the logs or contact the administrator”

@jangoetz ok, this time I got the error message, for the record:

 Return value must be of type ?int, float returned\",\"exception\":{},
Return value must be of type ?int, float returned\"}

Let me google it.

Looks like a known issue in Nextcloud 25 and it will be fixed in 25.0.2

Let me check their release schedule

1 Like

I am preparing a fix from their yet-to-be-released 25.0.2, should be ready tonight/tomorrow morning.
this issue only affects arm32 (ex: hc1/hc2)

Thanks a lot. What a great support!