Access issues (can't save settings)

Has anyone had this issue & know of a solution ? :

  • in the web interface under “settings” - then “access” both my ip v4 & v6 supports are turned off (my provider only uses v4). When I go to turn the ip v4 support on and set “Detect ip” to “auto”, (port setting is 443) & then click save i get this error : “Unable to verify open ports, using device public IP: ‘xx.xx.x.xx’ which is IPv4. Details: port is not reachable” (the ip shows my correct ip).

My router has Nat forwarding & port 443 set. I’ve been using the device for years, and randomly the other week i wasn’t able to access it from out side the network. I tried reading through as many threads here that i thought were similar in order to try & trouble shoot it on my own, as i was also having issues with nextcloud and syncloud updates ( but i’ll save that for another thread ) I feel I may have added more problems by trying to troubleshoot it without asking around first.


Hi Paul,

something a little similar happened to me 2 moths ago…
I used nextcloud for years, and suddenly, it does not work.
And had the same error, as yoy can see here:

In my case, the cause was an “upgrade”.
Now Syncloud not use UPnP, so the port that UPnP has managed on my routers for years, now was closed… and also, in my case, the upgrade ¨"switched on" the IPv6…



IP v4

Support: ON
Mode: Public
Detect IP: Auto
Public port: 443

IP v6

Support: OFF

And then, make sure you have in your router the 443 port opened four you Nextcloud internal IP.
Ensure also you are not in CGNat (some comanies thake you into CGNat without any warning)

1 Like


Thank you for your response. i spent some more time with it over the weekend and this week, still can’t get it fixed. I did see the thread you mentioned when i was trying to self trouble shoot the issue. The problem is the settings won’t save at all, it keeps showing an error that it can’t communicate with the host ip. Even though the ip address is correct & the settings on my router have the ip & port set to be accessible

Error message means your IP adress cannot be accessed from the internet. Either because it is not public or it is not on your router (carier grade nat)

Are you saying it is not correct?

Hi Boris,
I re-looked at the github link you provided. Made sure 443 tcp is open. The unable to verify open port shows my correct IP address (I did a quick ip lookup to make sure). I think the problem is Cgnat. My provider must have switched it recently. Does this mean I won’t be able to use my device anymore ?


… edit / update// i think i found some write ups on configuration changes i’ll have to adjust on my router. once i try those i will report back & hopefully close the ticket.