External Access (Works for some, but not for others)

Ive got my syncloud setup and running. Works great locally and when Im out and about on my cell service! however, Ive got a few family members that when they try to access my nextcloud instance they can’t from their home ISP (notably Comcast and Centurylink). when I visit them, I too am unable to access nextcloud without using a vpn or turning off wifi to use my cell provider. Is this an issue on my end or an issue with the DNS or an issue with their large ISP?

One explanation could be that your syncloud device is from extern accessible only by public IPv6 but not IPv4 (e.g. Dual stack lite) and that the others don’t have ipv6, you can test on ipv6-test.com

Correct, it is either IPv4 vs IPv6 or DNS.
Open the mentioned test page on both sides to check what IP versions you and they have.

Another reason is bad DNS, check on their side if they get the right IP by running:

nslookup [device_name]

Thanks for the help! ok, so when I visit that site on my laptop everything seems to load, when I visit the site on the computer that has my SyncloudVM ipv6 fails to load. When I visit https://www.syncloud.it, my external address is an ipv6 address… seems a bit screwy…

is there a way to make it auto detect my ipv4? If I turn off autodetect my IP in the access setting, and put my external IP in, everything seems to work! but If I use autodetect on it seems to switch my external to ipv6. and that seems to be causing the issue. I have uPnP turned off.

Sounds like this issue Dualstack IPv4 switch button · Issue #505 · syncloud/platform · GitHub

1 Like

anything I can do to fix it on my end?

only to keep on manual IP for now, you can always support the development.
This feature will be coming soon.