Syncloud DNS routes to Lan IP not Wan IP

Having trouble accessing a new syncloud device. Background, I have one syncloud device at “name” and wanted to upgrade to another device.
I first activated the new device with “testname” to try a few things without messing with my original device.
Then I wiped the test device, fresh install with Etcher, removed from my account from and then activated the new device with “name”, and updated software. Opened the ports on router to new device lan ip, attempted to enable external access and it fails “unable to verify open ports using external ip.”
But if I try to access device from external I get a certificate mismatch warning, the error shows that my certificate is for “testname”.syncloud instead of “name”
I tried to remove and install platform, then reactivate and the certificate now will correctly show “name” if accessed internally but any attempt from external source times out.
If I put “name” in a web-based server checker if states that "name" dns is pointing to a LAN ip not a WAN ip.
Logged into account shows device with correct domain, internal and external ip’s.
How can the DNS for my “name” correctly be pointed at my external ip instead of my Lan ip?
Repeated Etcher install/activations have not corrected this issue.
Thanks in advance.

Opened the ports on router to new device lan ip, attempted to enable external access and it fails “unable to verify open ports using external ip.”

You need to open 443 port on your router to point at your new device internal IP.

When you save external access do you have both ipv4 and ipv6 enabled, try just ipv4?

Do you have a public IP on your router or carrier grade nat where public ip is not on your router but somewhere inside provider network?

Yes, 443 is open to the new device. (Same setup as the previous syncloud device that worked well)
I can not save external access settings because it can not very the external IP. (This will not allow turning on public ipv4 or turn off ipv6)
Yes I do have a public IP.
I am concerned about the DNS, if you enter my “name” in an public server checker it states the my the DNS returns a private lan IP. Any attempt at external access times out because it is aimed at an unreachable lan IP 192.168.x.x.

External access is for setting dns to public IP.
Can you send a screenshot right before saving external access?
Also can you seng logs to support right after saving and getting error please?
Error means your IP and port is not accessible from the internet or is not pointing at this device.

Logs sent. Screenshot attached.

Ok, logs say your public IP 2**.*.*.5 port is not open.
And I can see that just by opening this https://IP in browser. You can test your self. When you create a port mapping on your router yoi can always check by opening it in a browser outside of your local lan (phone on mobile network).

Brilliant! I had checked that before reinstalling OS and reactivating and received an open result but now external port 443 is showing closed.
Rechecking the router settings, I had added this new device port map but not removed the old device port map from the router, I didn’t realize having two device with same port forward (443) would cause interference. It didn’t result in a closed port result right away but it must have been the cause of the certificate mismatch routing the same port to two different devices.
Removing the duplicate (old device) port forward has corrected the issue.
Thanks again for the prompt and competent support!