No acces: "500 Internal Server Error"

For some time now, maybe two or three weeks, I have been having the following problem:

Windows client does not conect, and shows this message:

(the English translation is:
No connection to Nextcloud at The server responded “500 Internal Server Error” to - PROPFIND")

When it happens to me, I click on the link (the one with the arrow), and the web version of Nextcloud opens in the browser.

From there, after 30 seconds the Nextcloud client “awakes”, connect and starts to synchronize.
And all works fine until my computer suspends, shuts down or restarts.

When I turn the computer back on, I have to do the same operation, otherwise hours go by without the client being able to synchronize.

I tried to change my client to another version (since yesterdeay, I had 3.3.6 and now I tried 3.6.4 and others…), but it happends the same.
I have the last versions of syncloud: System:1760 - Installer:312, and Nextcloud: Version: 660 - 25.0.2

Any ideas?

Do you any other clients like phone?
Sounds like client app/os issue, but can you send logs when it happens again and let me know here?

Yes, I have other client on phone, and the client on phone seems to work ok.
On the computer it always happens to me. I just sent you the log.

The behavior is the same in another user, with another client and in another computer: it does not connect, unless you follow the same trick.

I have tried to restart the server completely, even turning it off completely and turning it back on, but the behavior is the same.

All I see is this in the log, and this was happening because we had issues with our dns service and it was finally fixed yesterday late evening after this log. Was happening for few days and potentially for weeks.
This should not have caused any app issues unless your device changes its IP move than one time a day.

2023-01-27 16:28:27,280 - util - ERROR - <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<title>502 Proxy Error</title>
<h1>Proxy Error</h1>
<p>The proxy server received an invalid
response from an upstream server.<br />
The proxy server could not handle the request<p>Reason: <strong>Error reading from remote server</strong></p></p>
<address>Apache/2.4.18 (Ubuntu) Server at Port 443</address>

Could you send logs one more time right after this happens again please?

Hi, same problem and same behavior…

I just reboot Raspberry and Syncloud.
I waited for 5 minutes, and sended you logs before the trick and after it.

Do you have desktop client logs to send to support?

Also could you send to support the output of this command on the device (at least few lines):

journalctl | grep " 500 "

It is possible that 500 is actually coming from another server every time your device changes IP windows does not update dns quick enough. If that is the case then maybe DNS server you use in your network is not updating in time.

To check that you could set DNS on your windows to (google dns) which reflects dns changes properly.

More info: Unable to access device from local network · syncloud/platform Wiki · GitHub

Sorry, Boris.
At the end, I erased and re-install all… now works. I wait for a long time (fingers crosed)

I’m beginning to suspect that all the problems and the 3 reinstalls I’ve had to do may have a hardware origin…

At the moment, I have bought an original Raspberry power supply.

If it continues to give problems, I will change the SDD disk that has now 3 years of continuous use 24h