cloudflare tunnel configuration

I’m using cloudflare tunnel to access my home network externally.

When trying to access the apps on syncloud, I’m always routed to the default syncloud admin site, and not the app site.

Can you give me some suggestions on how to configure cloudflare tunnel to access the specific apps?

Hi, never used cloudlare tunnel myself.
The main issue usually is incorrect DNS.
How do you access your device by IP or DNS?

IP would give you only admin web.

To access apps you need to use dns and it needs to be updated with correct IP (usually happens automatically). Device has two modes to operate local and external. Local will update dns records to device local IP for local lan usage. External will try to guess your external (oublic) IP and update dns with it (will sync every 15 mins for dynamic IPs).

What is your mode, is your dns correct?

I’m using DNS internally only. the cloudflare tunnel software is installed locally on another server in my network. but for some reason, the nextcloud subdomain is resolving to the server IP and not the app?

cloudflare is free for home users, and is a great alternative to not opening ports on home firewalls.

nextcloud subdomain is resolving to the server IP and not the app?

I guess you have a public IP from cloudflare right?
Which tunnels all ports traffic to your device at home?
Domain name should point to that IP.

For example:
Your cloudflare ip

That way device sees and shows nextcloud.

Can you send me your domain name to support so I can check?

Please answer all the questions not just one as I will not be able to help otherwise.

I see, you are using a different public domain from device domain.

Public name:
Device name:

Device would show apps by matching [app]

That is why device always shows its default admin app because is not the same as

As a workaround you could try setting HTTP Host header to be the same as device for example

Ideally you activate your device with the same name you access it.