Can't operate after a change of router getting " Get "https://myexternalip.com/raw": x509: certificate has expired or is not yet valid" error

Hello, I’m a longtime user on a RPI4 + external USB disk

I’ve changed ISP and got a Vodafone Power Station router for a new Vodafone connection.

I’ve assigned the same fixed IP to the RPI4 running Syncloud, opened ports 443 and also 80 to that local IP, set UPNP ON on router. Results: no way to see the system.
I tried to open DMZ to that IP, no way.

I can only connect the Syncloud unit by addressing the local IP https://192.168.0.108 but after the login screen and after clicking on one of my apps (for example Nextcloud) nothing happens if I press OPEN

If I click SETTINGS it works. I then go to ACCESS and I get:

but when I press SAVE I get:

"#### Error

Get “https://myexternalip.com/raw”: x509: certificate has expired or is not yet valid: current time 1970-01-01T00:28:16Z is before 2022-04-19T02:28:24Z"

Is that the rteason of my inability to reach Syncloud on WAN?

More, when I log on https://www.syncloud.it/ I get:

Devices

myname.syncloud.it

Raspberry Pi 4

Domain Address: https://myname.syncloud.it
External Address: https://109.112.172.xxx
Internal Address: https://192.168.0.136
IPv6 Address: Not provided
Updated: May 18, 2022

I do not recognize none of the IP addresses indicated there, nor local nor external

Don’t know how to proceed :frowning:

Thank you for you attention

Marco

Looks like time is wrong on the box, can you run this command using ssh:

date

If date is wrong, you can fix it using this instruction: Time · syncloud/platform Wiki · GitHub

Right:

root@syncloud:~# date
Thu Jan 1 00:04:21 UTC 1970
root@syncloud:~# ^C
root@syncloud:~# service ntp stop
root@syncloud:~# ntpd -gq
ntpd: time set +1654107099.281775s
root@syncloud:~# service ntp start
root@syncloud:~# date
Wed Jun 1 18:17:31 UTC 2022
root@syncloud:~#

But after a shutdown i get again:

root@syncloud:~# date
Thu Jan 1 00:04:21 UTC 1970

It’s an RPI4, is there a battery to check? Or should it pickup time and date automatically?

Thanks

I see, what image are you using?
You can check it by running these commands:

lsb_release -a
uname -a

Here is it:

root@syncloud:~# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux 8.11 (jessie)
Release: 8.11
Codename: jessie
root@syncloud:~# uname -a
Linux syncloud 4.19.57-v7l+ #1244 SMP Thu Jul 4 18:48:07 BST 2019 armv7l GNU/Linux
root@syncloud:~#

Currently I can access my Syncloud on RPI4 only from local LAN IP, via local or WAN IP but only from within my LAN.

No way to connect my xxxx.syncloud.it or WAN IP address from outside.

More, I can’t access my Nextcloud installation with proper user/pw combinations. I get the login page reloading over and over with no error messages

All the above happens with or without a time-date sync after boot, that doesn’t appear to be critical.

Everything happened after I changed ISP from Telecom to Vodafone. Of course I had properly set up port forwarding and IP reservation.

I run Dietpi on another RPI4 wich I can access locally and from outside my LAN with no problems.

I’m thinking about restarting Syncloud installation from scratch but I wonder if I will retain our data on external USB storage provided that I keep the same login/pw combination

Thank you for your support, Boris.

Marco

This is a bit old installation, can you reinstall using the latest arm64 image: https://github.com/syncloud/image/releases/download/22.02/syncloud-raspberrypi-64-22.02.img.xz

Usb storage is ok to reuse of cause, keep the same login.

Thanks.

Can I also keep using my current Syncloud account? Just to be sure…

Of cause, you need to use your existing syncloud.it account otherwise you will not be able to reuse your domain name,