Can't access from my domain in the local network

Today I have realized that I cannot access from my domain in the local network, which I could before.What has changed or what do I have to do?


This maybe related to a missing feature on your router, here is more details: Unable to access device from local network · syncloud/platform Wiki · GitHub

Can you tell which router name and model are you using?

I am using an Arris TG4482A

I was searching on google and it seems that NAT Redirect/Loopback has been disabled in some routers or internet companies by default, and I have not found how to enable it. But the funny thing is that it worked for me until a couple of days ago.

Same thing happened to me about a year ago. Everything working fine then next day, nope. Xfinity made a change and that was it. Phone calls to their support staff were less than helpful.

before I buy 1 of these to try, this sounds like it may be a hardware solution.

this would allow the setup of a secondary VLAN and you could connect the Syncloud device to it which would put it on a separate LAN.

think this’ll work?

I have the same thing to extend amount of devices I can connect to my router. I do not think it will change anything related to Nat Loopback as you are trying to access your local network device by external router adress + port mapping back from local network and router does not like it.

To debug try to open these in your browser (this is only for IPv4 inside and outside of your network).

From local network:

  1. https://[router external ip]:[port mapped to your device]

should work only if you have nat loopback enabled

  1. https://[local network device ip]

Should always work.

From the Internet:

  1. https://[router external ip]:[port mapped to your device]

Should always work.

  1. https://[local network device ip]

Should never work.

@juanperez I think one option is to put your Arris modem into a bridge mode that will disable router features on it and connect another router (with nat loopback feature) and then connect all your devices.

I think any tplink routers support that but check before buying.

I would have liked to do the solution that you had explained with pi-hole. For now I’ll have to modify my hosts until I buy a new router.

Pi-hole is also ready, please try to create custom dns entries pointing at your device local IP, one for device and one for each app. Then if your router has your device as a orimary dns server all local network clients should be able to access Syncloud device and its apps.

Im moving into an area next week that the only option is Xfinity/Comcast I signed up for a XFi not knowing that this is an issue. I really hate Comcast…

Is there a work around?

With the Comcast router I have (not sure about the xfi unit), the DNS is hardcoded and can’t be changed so the pi-hole option won’t work. Only option for me is either VPN (which is what I am currently doing) or getting another router and setting the Comcast unit to bridge mode (which is what I will be doing as soon as I get the time to set it up). Setup is fairly simple as I’ve done it before, just irritating that I have too…

I hate Comcast…

if you don’t mind me asking, what Router are you going with?

i seem to prefer the netgear units. any of the mid to high range ones should be fine. I picked up an AX1800 unit a few months ago that i never got around to installing. I was going to install hopefully this weekend.