Problems installing Syncloud on new PC

Hi, Ive run Syncloud on an Odroid HC1 for a couple of years. Ive now bought and assembled a proper server. The problem is that the installation of Syncloud is proving impossible.
Ive tried both UEFI and Legacy versions. The Legacy version at least permits it to boot, but it will only ever boot from the flashed USB.
With the UEFI, there is nothing.
I played around with the BIOS settings in the hope that something was wrong there. Nothing helped.
Eventually last week I got a computer shop to try to install it. They too couldnt manage it, but they did manage to install Ubuntu server instead.
Im thinking the problem is lying somewhere with the UEFI version (probably the one that should work with my new x64 server) - any suggestions?

  1. What is the name of the PC and BIOS?
  2. Does it have any settings about Legacy or UEFI boot mode?
  3. If you installed Ubuntu on it can you run this command to check which mode it is running in:
ls /sys/firmware
  1. Motherboard is: WS C246M Pro - ASUS
  2. I can’t see any settings about Legacy or UEFI boot mode. It seemed to work booting legacy - but only from the USB flash.
  3. acpi dmi efi memmap

Is ubuntu running from usb or from sata disk?

From Sata disk. Actually it is Ubuntu desktop that was installed.

Should I try again to install with UEFI? Is there any particular settings I should use for the flash? NFTS/FAT?

I’ve just tried to install the UEFI again. This time, I had some success - I was able to select the USB flash as the boot method.
What happens now though is that it boots straight to nextcloud - I didn’t get into the syncloud settings at all. Any ideas what might have happened? It is very strange.

How are you writing Syncloud image? Etcher on another PC to ssd disk and then insert into this one and boot?
You should not use USB flash.

I’ve been using etcher on a USB flash. So, I should install onto the ssd using another computer and then put it back into the server computer?

I tried with installing on the SSD - in the BIOS it can see the SSD. However, it does not boot from this - it says there is no bootable disk. I tried resetting all the BIOS to default. Didn’t help.

Yes you need to write the image directly to ssd disk and then insert it to the PC and remove all other removable disks.

Can you show BIOS screenshot with Boot menu?

I did this but it doesn’t like the SSD for some reason. I got it working on a small M2 ssd. I reset the BIOS settings to default. This hasn’t helped. It can see the SSD and it says it is the bootable drive, but it doesn’t then boot from it. I need to check if it is formatted correctly or if there is a problem with this (new) drive. I’ll let you know.

Do you have validate enabled when you write image with Etcher?

Yes, it is validating. After some problems with playing with the BIOS settings, I have now got the syncloud installed with the bigger 2tb ssd.
I managed to register it on my domain. After I installed syncloud I updated to the latest version, then expanded the memory.
Then I installed Nextcloud. The problem is, Nextcloud will not open. I can’t also logout, restart or shut down. It says - server error. I have sent logs to you.
I have also tried to remove Nextcloud, but it won’t allow that either!

Could you send logs one more time (make sure you include support)?

Also it would be great if you could tell what BIOS setting actually fixed it and what type of image you used in the end
It would help future readers with the same issue.

Sent just now, thanks.

I used the UEFI image. I’ll take a look at the BIOS - the guy who helped me sort it out showed me the setting which needed to be switched from legacy to UEFI. The motherboard I have seems to have a much larger range of settings than usual ones do.

Ok, let’s create a separate thread for custom domain questions as they are not related to hardware.

Hi - this problem has all been solved now. The main issue I had was that it was not booting.

This turned out to be two problems - firstly I was trying to boot legacy instead of UEFI (make sure you use the right one) and secondly I needed to have the BIOS settings correctly set up for UEFI.

After that, the Nextcloud installed but wasn’t booting - this turned out to be a problem with my ports not being opened and configuration. Once I corrected these, everything has been working perfectly again.

Thanks Boris for all your help.