Odroid HC4 not reachable and shows no output on cli


i want to setup an new syncloud enviroment to escape from arm86(Odroid HC2).
I bought a Odroid HC4 download the current image (syncloud-odroid-hc4-23.09.img.xz), flash it on a SD-Card put it in and power the device. Sadly nothing happend.
The device don’t answer via browser and i get no out put on the console when i plug-in a hdmi cable.

To prove the sd-card and the hardware is working, i flash it with the odroid os(ubuntu-22.04-4.9-minimal-odroid-c4-hc4-20220705.img.xz). This one works well and is reachalbe and shows me the console.

please help me.

best regards

Strange, I guess you teied this one:


Can you try this one:


I will test 23.09 later as well.

Hi Boris,

thanks for your replay and investigations.

The sd-card is the problem i use a Samsung Evo Plus 128GB (SDXC) U3.
I tried the other image an get the same problem with the named sd-card.
After i took the old sd-card(SanDisk Industrial 8GB U1 Class 10 HC I) from my old device(current syncloud device) and flash it with the newest image syncloud-odroid-hc4-23.09.img.xz it worked.

I’m a bit surprised because the other odroid image (ubuntu-22.04-4.9-minimal-odroid-c4-hc4-20220705.img.xz) worked very well with the Samsung sd-card. It must be because of the debian buster image or the special syncloud image.

Thanks for the reply, strange I think image is 3g itself and it should not matter how big is the card. Usually you do not need big sd cards and add external storage ssd disk especially on this hc4 device.

Dear @boris , I have a similar issue. Trying to set up a new HC4 device with a SD. I tried 3 builds.


I can get the logs via the petitboot interface. I have the error message “PXE autoconfiguration failed”. I also tried to change boot order but nothing happening.

(I’m premium subscriber)

Would you have any idea what to investigate?


Could you send your odroid hc4 picture?
Do flash using etcher?
Is ercher verify enabled?

Do you mean by picture, a picture of the device? It has a OLED display but nothing else special about it.

I used etcher and everything was green.

I updated petitboot by pb-update

There is mmcblk1p1 and mmcblk1p2, maybe this is confusing?

After SD Card flashing there are two mounts on the Laptop (boot and rootfs).

I tried to boot by holding Boot switch pressed (on bottom side), but did not succeed.

I did not test another SD card yet, but this one was running before with Syncloud in an old Odroid device.

eth0 has internal IPv4

MAC address is same as in the router setting

Are there logs on the SD card that could help?

I used etcher and everything was green.

Sorry do you mean you could boot the device and use it at this point? No boot errors or anytning?

No, by green I mean during flashing process with etcher. What did you mean with etcher verify enable? Is there something to do on the device config?

Sorry i forgot the “not”. Let me know if i can provide any helpful logs.

Just tested another SD card and NOW it works! But I dont think that the other SD card was defect. Its maybe more like the other SD card was already partitioned because of Syncloud image flashing and I didn’t get it to flash the SD card all in one. If you have more ideas about that, you might want to add some information to the wiki how to flash the SD card correctly…

What we have on the wiki is correct, use etcher to write the mage.
Image contains all the partitions, so etcher will remove the existing ones.
The usual source of the problem is broken sd card or mounted sd card at the time of writing (etcher should warn about it).
What OS are you using to write the image?

Is it possible that this caused the boot issue?

Ok, that was the thing I was not sure about.

Ok, there was no warning but the OS mounts the SD card by default I guess? It depends if you understand that the icon in the file explorer appears as mounting? This is before and after flashing…

Ubuntu 22

No, I did not change anything after that. Just used another SD card. It’s also documented getting_started:petitboot:os_installation_using_otg [ODROID Wiki]

But anyway, I’m fine now, Thanks for your help.

there was no warning but the OS mounts the SD card by default I guess? It depends if you understand that the icon in the file explorer appears as mounting?

Yes, I think Ubuntu mounts automatically.


I still think etcher unmounts it for you.

So most likely just a bad sd card.

Hello everyone!

I received my Odroid H4 last Wednesday and I tried to set it up according to the instructions.
Sadly, I could not reach the device via webbrowser (desktop). I also used the Syncloud app and innitialy the device was visible. I even installed the Nextcloud app, but what happened after is a mystery.

No matter what I tried, the device has not been visible since then.
Restarting it (disconnecting the power), restarting my modem/router and confirmed that it’s setting are correct.
I even canseled my Syncloud-account and signed up again. The device remains invisible.

Sending multiple mails to the support department didn’t result in a response. I now consider to send the device back to sender, but who knows for sure if I get my money back?

I’m desperate.

No response, no support, leaving me no choice than to send the device back to sender.
I sincerely hope I’ll get my money back.

Hey sorry for the delay, why did not you send us the email to support?
Can you give us a chance to help you?

Sorry our email server somehow blocked the emails for the last few days and I just received them all.

Anyone reading this in the future, please do not make rush decisions, I do this for last 10 years and the last thing I want is to steal your money. Please do not be afraid that I will not refund a failulty device even if it is after two weeks. Please wait for my response to your problem and then we can agree on something and it is usually in customer favor. I understand we all want instant support but let’s be honest top companies in the world do not provide it either.