How to restart the Jellyfin server?

Title. Tried adding some plugins to Jellyfin, tried to restart as it said, it won’t restart. I’ve tried multiple different commands via SSH, but no dice. snap services tells me that jellyfin.nginx and jellyfin.server are enabled and active, but trying to connect to my Jellyfin server in any way won’t work. Help would be much appreciated. Sorry if this is rather short; I’m very tired rn haha.

What plugins?
How did you add them?
Did it stop working after you added them?
Did you try reinstalling jellyfin to bring it back?

  1. I don’t remember which plugins specifically, to be honest; I know I added the Kodi Sync plugin, but other than that I don’t remember. I did add an external plugin repository and might’ve enabled a plugin or two from that, but like I said, I don’t remember exactly.
  2. I added them via the Jellyfin webUI.
  3. I guess so? I installed them and Jellyfin told me I had to restart the server for them to be actually enabled, so that’s what I tried to do. I’ve never tried to restart the Jellyfin server, so it could easily be either just trying to restart it or the plugins themselves. How would I go about removing the plugins without being able to access the server?
  4. Yes, I did, at least twice via the Syncloud webUI.

Ok, if some plugin breaks jellyfin we need to see logs to understand how to fix it.

You can see logs yourself if you want either by running this command:

journalctl jellyfin.* -f

Or from Settings - Support which can send them to you by email or even include a copy for support to help you.

1 Like

Okay, this is weird. I ran the command you said, but I get this error: Failed to add match 'jellyfin.*': Invalid argument. I ran it character-for-character btw, if I was supposed to substitute the asterisk for something else I didn’t haha. Running journalctl jellyfin gives the same error. And I know I have jellyfin installed right now; I just checked, and I can still open the app (going to https://jellyfin.[my domain]) which brings me to the server select screen. (I should’ve mentioned that in my initial post; attempting to access the Jellyfin webUI via the link brings me to a server selection screen where I can click on my server and then click connect but it fails to connect.)

I got the logs via email like you said, but they’re very long and I don’t think I have the skills to glean any useful info from them. I did make sure the “Send a copy to support” switch was on, so hopefully you’ve gotten it? If not let me know, and how I should send it to you. (My box isn’t set up to be able to be accessed from off the local network yet, so…)

Jellyfin seems to be runnig ok from the logs.
Can you show what you see when opening jellyfin.[domain]?
I see login prompt to jellyfin.


Below here is what I see immediately upon accessing jellyfin.[domain]. (Cropped for privacy)

And below here is what I see when I click on the Dragon’s Nest (the name of my server) icon.

Finally, below here is what I see about 1 or 2 seconds after clicking Connect.

Thanks for helping me out.

Can you check browser’s network tab in developer tools window to see if it is trying to access correct domain name?

Ok, when you change domain browser will still remember you old jellyfin server, so what you do is add new server on this screen and give it you jellyfin domain url like jellyfin.[domain] and it should open your server login prompt.