Sending e-mail with a Mail App does not work

Hi there,

I got the browser-based Mail app in syncloud working. Configured the account in Thunderbird app following the instructions on the Wiki. Receiving e-mails works, but sending does not. Used configuration for SMTP:

Server: [custom domain]
Port: 587
Security: STARTTLS
Authentication: Password, normal
Username, password: same as in roundcube

When sending an e-mail, Thunderbird keeps telling that the certificate has an invalid signature. “The configuration for [custom domain] must be corrected.”

Is your device certificate valid? For example what browser say when you open it.

Yes, it seems so. Browser does not complain either.

Just tried it with the Android mail app. It also struggles with the SMTP configuration from syncloud, but with a different error message: “No secure connecion to the server possible (handshake failed).”

Edit: here the screenshot from the android mail app SMTP-configuration:

another thing, if you get certificate after you installed mail app it may still have the old one (which is not ideal if true), can you try this to test:

snap restart mail

Unfortunately this did not succeed (error message still the same).

can you send your domain name to so I can check the ssl error?

Just tried connecting to your server using Android K-9 Mail.

SMTP Server: [custom domain] does not give certificate error but of cause I cannot connect as I do not know the password.

Anything other than [custom domain] for example smtp.[custom domain] gives certificate error.

Can you try K-9 Mail on Android just to compare?

In Thunderbird I only get ‘wrong username or password’.
Did you select Authentication method: Normal password?

Here are the settings in K-9 Mail:

Password is the same as in Roundcube. The Error message in K-9 Mail is “Connection to the Server is not possible. ()” upon trying to complete the outbox server configuration.

In Thunderbird the Authentication method is Normal password. Server is [custom domain] Without any prefix.

Bildschirmfoto vom 2022-01-16 14-33-03

In Thunderbird the synchronization of the mail folders is working and I am getting Mails in the Received folder. Only Sending of E-Mails is not working.

strange, can you attempt one more time and send logs to support from Settings - Support?

Is this your time of the attempt?

Jan 16 21:53:35 syncloud postfix/submission/smtpd[17398]: warning: TLS library problem: error:1409441B:SSL routines:ssl3_read_bytes:tlsv1 alert decrypt error:s3_pkt.c:1472:SSL alert number 51:

Strange I cannot see many attempts, can you try few more times and send logs again?
Also are you on latest version of Mail and Platform (System - Updates)?
Could update first if it is not latest.

OK, just tried several times from Thunderbird with no success (around 11:00 pm). Also sent a test E-Mail from Roundcube from the same e-mail account to you. That one you probably should have received(?)
After that sent syncloud logs. The strange thing I noticed, that even the failed e-mail sent attempts in Thunderbird land correctly in the draft folder of Roundcube.

Yes, syncloud should be up-to-date as well as the installed apps:



That one you probably should have received

Let me check the logs.

Strange nothing right now, can you try one more time, just sending to get the error from Thunderbird and mobile, many times and then send the logs right away.
Do not attempt to use Roundcube for now as it produces a lot of good logs and I cannot see the bad ones.

Alright, 10 attempts from Android and 10 times trying to send e-mail from Thunderbird. Sent syncloud logs immediately after that.
In the Android mail app I could not complete the mail setup because of the error, so I did 10 attempts to complete the setup.
I believe the errors are seen in the logs at Jan 19 14:49:32.

OK, it is the same error as above:

Jan 19 14:49:28 syncloud postfix/submission/smtpd[12904]: connect from unknown[***]
Jan 19 14:49:28 syncloud postfix/submission/smtpd[12904]: SSL_accept error from unknown[***]: 0
Jan 19 14:49:28 syncloud postfix/submission/smtpd[12904]: warning: TLS library problem: error:1409441B:SSL routines:ssl3_read_bytes:tlsv1 alert decrypt error:s3_pkt.c:1472:SSL alert number 51:
Jan 19 14:49:28 syncloud postfix/submission/smtpd[12904]: lost connection after STARTTLS from 

one thing before we start digging certificate issue, can you create a user for me to test, you can remove it later and send me credentials by mail or pm?

ok, 993 port certificate is not good for some reason.

this command does not like it either:

openssl s_client -connect [domain]:587 -starttls smtp

443 and 993 ports are fine while they all use the same cert.

as an attempt to try something can you generate new cert?

mv /var/snap/platform/current/syncloud.crt /var/snap/platform/current/syncloud.crt.bak
snap run platform.cli cert
snap restart platform
snap restart mail

Done that. No changes :frowning:

Ok, can you try to remove mail and install again?