Mail: start error during install

Hi Boris,
I have tried to install this app. Unfortunately it fails. Here follows the error:

root@syncloud:~# sudo snap install mail
error: cannot perform the following tasks:
- Start snap "mail" (239) services ([start snap.mail.php-fpm.service snap.mail.o                         pendkim.service snap.mail.nginx.service snap.mail.postfix.service snap.mail.dove                         cot.service snap.mail.postgresql.service] failed with exit status 1: Job for sna                         p.mail.postfix.service failed because the control process exited with error code                         .
See "systemctl status snap.mail.postfix.service" and "journalctl -xe" for detail                         s.

I’m running an Odroid HC4 with :

root@syncloud:~# hostnamectl
   Static hostname: syncloud
         Icon name: computer
        Machine ID: b65ee67f8c094915aa9809c66458a868
           Boot ID: 49d5289a913044108909507304977352
  Operating System: Debian GNU/Linux 10 (buster)
            Kernel: Linux 4.9.236-63
      Architecture: arm64

Thanks for your help


p.s.: this topic is apparently VERY similar to this one but the errors on console are different. Here’s why I preferred to open a new thread. Thanks

Could you send logs from Settings - Support?

just done, immediately after having tried to install Mail. Thanks, ciao

Looks like something is already running on mail port 25:

syncloud postfix/master[29191]: fatal: bind port 25: Address already in use

Did you install anything on the device not from Syncloud store or maybe configured some app to become mail server (not sure if that is possible)?

Can you check what is running on that port?

netstat -lnp | grep :25
root@syncloud:~# netstat -lnp | grep :25
tcp        0      0  *               LISTEN      2703/exim4
tcp6       0      0 ::1:25                  :::*                    LISTEN      2703/exim4

I have googled “exim”. It’s a package related to mail processing. Just removed, Mail installed successfully:

root@syncloud:~# sudo snap install mail
mail 239 from 'syncloud' installed

. Thanks a lot!

Did you install exim yourself before that?

no, I suppose that I got it installed as a dependency during some manual installation. During the last few months I have tried very few apps via apt-get. Some of them, I suppose, are designed as desktop environment application and could have lead to “tons” of packages installed as dependencies. I have just run apt autoremove but very few packages have been removed. Example: I have tried Qbittorrent just yesterday…it was a huge installation…then I have discovered qBittorrent-nox, a light version with a web gui.

Hi Boris,
I think this is interesting for you:

  1. I’ve just reflashed (with latest image :wink: )
  2. manually installed mdadm to assemble my RAID1 disks;
  3. activated it;
  4. installed nextcloud → OK;
  5. installed → OK;
  6. installed mail → same error due to “exim” running on port 25.

So my answer to your question is: I really don’t know when exim was installed during those steps :exploding_head:
Anyway, I know the solution. This message is for the sole purpose of giving you useful information.


Probably from step 2?
Can you reflash the image and install mail right away?

Latest just in case:

hi Boris,
I have not spent any time with Syncloud during the last days, I beg you pardon.
I will not reflash due to lack of time :wink: but I’m gonna look for the reverse dependencies of exim4 and related packages. Apt-get command has on option to do that. As soon as I’ll spend time on Syncloud I’ll do that.

Ok, at least you can install mail now.

For the use of apt we should disable it by default and allow enabling it with a big warning “IT WILL BREAK YOUR SYSTEM” :slight_smile:

For the mdadm itself I am am actually working right now on adding a multi disk support to our storage UI which will use btrfs and drops the need for any manual command line setup.

1 Like

I have looked for rev dependencies of exim4. They are too many:

root@syncloud:~# apt-cache rdepends  exim4
Reverse Depends:

Being that we suspect mdadm to be guilty :wink: I have done also the opposite:

root@syncloud:~# apt show mdadm
Package: mdadm
Version: 4.1-1
Priority: optional
Section: admin
Maintainer: Debian mdadm maintainers <>
Installed-Size: 1,223 kB
Depends: libc6 (>= 2.28), udev, debconf (>= 0.5) | debconf-2.0, lsb-base, debconf
Recommends: default-mta | mail-transport-agent, kmod | module-init-tools
Suggests: dracut-core
Tag: admin::boot, admin::configuring, hardware::storage, implemented-in::c,
 implemented-in::shell, interface::commandline, interface::daemon,
 role::program, scope::utility, use::configuring, use::monitor
Download-Size: 425 kB
APT-Manual-Installed: yes
APT-Sources: buster/main arm64 Packages
Description: tool to administer Linux MD arrays (software RAID)

So, it looks like some “mail” stuff is at least recommended.
I’m aware that those info are quite incomplete, if I can help you in some way I’m here. Ciao