Cannot update the System to 2161

My system is at rev. 2046, the Settings:Updates shows available update to rev. 2162 but when I click to update it spins a “waiting” indicator for couple of seconds and does nothing. I tried updating couple of weeks ago, and yesterday, and today. Same behavior. I just sent the logs via Settings:Support.

Can you show output of

snap refresh platform

Here is the output from this command:

root@syncloud:~# snap refresh platform
error: cannot perform the following tasks:

  • Run post-refresh hook of “platform” snap if present (run hook “post-refresh”:

/drone/src/backend/cmd/post-refresh/main.go:23 +0x13 fp=0xc0000c75b0 sp=0xc0000c7598 pc=0x8a8693
runtime.call16(0xc000203440, 0xb7ef90, 0x0, 0x0, 0x0, 0x8, 0xc0000c7b00)
/usr/local/go/src/runtime/asm_amd64.s:747 +0x43 fp=0xc0000c75d0 sp=0xc0000c75b0 pc=0x46b2e3
runtime.reflectcall(0xacba80?, 0xc0000f45a0?, 0x1?, 0xb3ff1c?, 0x0?, 0x12?, 0xacba80?)
:1 +0x36 fp=0xc0000c7610 sp=0xc0000c75d0 pc=0x46f6d6{0xa7d980?, 0xb7ef90?, 0x1?}, {0xb39aaf, 0x4}, {0xc000012d08, 0x1, 0xacba80?})
/usr/local/go/src/reflect/value.go:596 +0xce7 fp=0xc0000c7c20 sp=0xc0000c7610 pc=0x49cd27
reflect.Value.Call({0xa7d980?, 0xb7ef90?, 0xb7ef90?}, {0xc000012d08?, 0x8a4e3a?, 0x0?})
/usr/local/go/src/reflect/value.go:380 +0xb9 fp=0xc0000c7c98 sp=0xc0000c7c20 pc=0x49bdf9, {0xa7d980, 0xb7ef90})
/go/pkg/mod/ +0x12d fp=0xc0000c7d08 sp=0xc0000c7c98 pc=0x7d378d
main.main.func1(0xc0000de300?, {0xb39a37?, 0x4?, 0xb39a3b?})
/drone/src/backend/cmd/post-refresh/main.go:22 +0x6d fp=0xc0000c7d58 sp=0xc0000c7d08 pc=0x8a872d*Command).execute(0xc0000dc580, {0xc0000360b0, 0x0, 0x0})
/go/pkg/mod/ +0x694 fp=0xc0000c7e40 sp=0xc0000c7d58 pc=0x5a2e54*Command).ExecuteC(0xc0000dc580)
/go/pkg/mod/ +0x389 fp=0xc0000c7ef8 sp=0xc0000c7e40 pc=0x5a3409*Command).Execute(...)
/drone/src/backend/cmd/post-refresh/main.go:28 +0x4b fp=0xc0000c7f40 sp=0xc0000c7ef8 pc=0x8a860b
/usr/local/go/src/runtime/proc.go:267 +0x2bb fp=0xc0000c7fe0 sp=0xc0000c7f40 pc=0x43d69b
/usr/local/go/src/runtime/asm_amd64.s:1650 +0x1 fp=0xc0000c7fe8 sp=0xc0000c7fe0 pc=0x46cd81

goroutine 2 [force gc (idle)]:
runtime.gopark(0x0?, 0x0?, 0x0?, 0x0?, 0x0?)
/usr/local/go/src/runtime/proc.go:398 +0xce fp=0xc00005afa8 sp=0xc00005af88 pc=0x43daee
/usr/local/go/src/runtime/proc.go:322 +0xb3 fp=0xc00005afe0 sp=0xc00005afa8 pc=0x43d973
/usr/local/go/src/runtime/asm_amd64.s:1650 +0x1 fp=0xc00005afe8 sp=0xc00005afe0 pc=0x46cd81
created by runtime.init.6 in goroutine 1
/usr/local/go/src/runtime/proc.go:310 +0x1a

goroutine 3 [GC sweep wait]:
runtime.gopark(0x0?, 0x0?, 0x0?, 0x0?, 0x0?)
/usr/local/go/src/runtime/proc.go:398 +0xce fp=0xc00005b778 sp=0xc00005b758 pc=0x43daee
/usr/local/go/src/runtime/mgcsweep.go:280 +0x94 fp=0xc00005b7c8 sp=0xc00005b778 pc=0x429714
/usr/local/go/src/runtime/mgc.go:200 +0x25 fp=0xc00005b7e0 sp=0xc00005b7c8 pc=0x41e8e5
/usr/local/go/src/runtime/asm_amd64.s:1650 +0x1 fp=0xc00005b7e8 sp=0xc00005b7e0 pc=0x46cd81
created by runtime.gcenable in goroutine 1
/usr/local/go/src/runtime/mgc.go:200 +0x66

goroutine 4 [GC scavenge wait]:
runtime.gopark(0xc00007a000?, 0xc03978?, 0x1?, 0x0?, 0xc0000071e0?)
/usr/local/go/src/runtime/proc.go:398 +0xce fp=0xc00005bf70 sp=0xc00005bf50 pc=0x43daee
/usr/local/go/src/runtime/mgcscavenge.go:425 +0x49 fp=0xc00005bfa0 sp=0xc00005bf70 pc=0x426fe9
/usr/local/go/src/runtime/mgcscavenge.go:653 +0x3c fp=0xc00005bfc8 sp=0xc00005bfa0 pc=0x42757c
/usr/local/go/src/runtime/mgc.go:201 +0x25 fp=0xc00005bfe0 sp=0xc00005bfc8 pc=0x41e885
/usr/local/go/src/runtime/asm_amd64.s:1650 +0x1 fp=0xc00005bfe8 sp=0xc00005bfe0 pc=0x46cd81
created by runtime.gcenable in goroutine 1
/usr/local/go/src/runtime/mgc.go:201 +0xa5

goroutine 5 [finalizer wait]:
runtime.gopark(0xb35b60?, 0x10043ec01?, 0x0?, 0x0?, 0x445ca5?)
/usr/local/go/src/runtime/proc.go:398 +0xce fp=0xc00005a628 sp=0xc00005a608 pc=0x43daee
/usr/local/go/src/runtime/mfinal.go:193 +0x107 fp=0xc00005a7e0 sp=0xc00005a628 pc=0x41d967
/usr/local/go/src/runtime/asm_amd64.s:1650 +0x1 fp=0xc00005a7e8 sp=0xc00005a7e0 pc=0x46cd81
created by runtime.createfing in goroutine 1
/usr/local/go/src/runtime/mfinal.go:163 +0x3d

rax 0x0
rbx 0x4b0e
rcx 0xffffffffffffffff
rdx 0x6
rdi 0x4b0e
rsi 0x4b0e
rbp 0x6
rsp 0x7ffef94d1e20
r8 0x7
r9 0x1336130
r10 0x8
r11 0x246
r12 0xc46caa
r13 0x25
r14 0xc358f7
r15 0x133a750
rip 0x98bcbb
rflags 0x246
cs 0x33
fs 0x0
gs 0x0

What kind of device is this?
Have you installed anything on it using command line other than using Syncloud web?

It is an x86_64 mini computer:
uname -a
Linux syncloud 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt25-1 (2016-03-06) x86_64 GNU/Linux

I do not recall ever installing anything outside from what Syncloud provides.

Interesting, could you try this command:

snap refresh platform --channel=master

Seems that worked:

root@syncloud:~# snap refresh platform --channel=master
platform (master/stable) 2163 from Syncloud** refreshed

Though seems this command updated my system to 2163. The web page still say that there is new update 2161 even though it shows it is on 2163. Is that worrisome?

Ok, at least I have isolated the problem a very specific part of code.
I will push the update and update notification should go away.
I will let you know.

Thank you Boris for fixing this!

1 Like

This should being it back to stable, if it doesn’t update automatically (it should within couple days)

snap refresh platform --channel=latest/stable

That worked and now my system is on 2164. Thanks again!