Gogs ssh don't work

Hello support,

I two problems with the gogs configuration (version 184).

the link to clone the repository with https have extra char :0 :face_with_diagonal_mouth:

I remark that it the same things for all applications from syncloud .

This address is restricted This address uses a network port which is normally used for purposes other than Web browsing. Firefox has canceled the request for your protection.

And it not possible to use ssh because the user git can’t open a shell.

If i modify false by bash it’s OK


What is your system version (Settings - Updates)?
What is the activation (free/premium/custom)?

Hi Boris

System version 1723.
premium Domain galicien.me


ok I see, you did not enable external access, right?
I assume you want internal only mode?

Also could you show the output of this command please:

/snap/platform/current/bin/cli config get platform.manual_access_port

Hello Boris

No this serveur have a ix IP.

It OK i Change this setting.
But gogs have allways a parameter external url with the :0

Brand name Syncloud
Run user git
Run mode prod
External URL https://gogs.galicien.me:0/
Domain gogs.galicien.me
Protocol unix


the result : 443

It not very imortant : i can modify manually
the https url in gogs reository : https://gogs.galicien.me:0/pboizot/poney-gogs.git

Where can i modify this in config on the server?


Sorry I am trying to fix it properly for everyone.
Try running this:

snap refresh gogs

Hi Boris,


snap refresh gogs
gogs 184 from ‘syncloud’ refreshed

it’s OK for the external URL


ok, seems like you need to login to /bin/bash got git to work I was always under impression you need to lock it in some way, tried setting git-shell did not help, gogs mentions /bin/bash, can you set set it to see if that helps?
Tried locally looks like it helps.

I will push both fixes in the next gogs update, but default shell has to be manually changed on existing installations for now.

Hi Boris
I do the change , it work fine.