Extend Internal Memory in VMs past 2tb

when I first started my vm I maxed (or so I thought) the drive at 2tb, I just found out you can extend past the 2tb using the command line. So, I expanded the drive to 5tb and relaunched. My internal drive shows 2tb with the extend the button showing (like before) and when I press it, I get the busy wheel but it disappears quickly and nothing happens. the 2tb and the extend button are still present. Ive restarted the VM to refresh things but its still the same.

Any thoughts?

That is probably because VM image is based on msdos partition table while plain device images already have an option of gpt patrition table.

Can you show the output of this command inside VM:


PMed you a screen shot of the output!

@boris Do you think there is a chance to extend it past 2tb? I purchased a syncloud-h (that showed up today!) but would almost prefer to run the VM so I don’t need to buy another external HDD. I have plenty of storage in my Win10 server. thanks for all your help!

One thing you should try is to add an additional disk instead of extending the internal one.
Then activate that disk from Settings - Storage.
That is preferred way anyway to separate data and operating system files.
I think on external disk we already do GPT partition if you click format button.

right, external disk format is gpt:

Perfect! That worked! thank you so much for that!