Bitwarden Attachments

Been using the Bitwarden (Vaultwarden) app for a while and it’s been working great. Just recently tried using the attachment feature. questions though:
On my windows PC (using the Bitwarden portable app) and the Chrome extension, I can upload and download the attachments no problem.
When I tried the same with my 2 android devices (android 13) I get the spinning “Downloading…” dialog then after a minute or 2 I get “Unable to download the file”.

after doing a bit of research on the Bitwarden forums I found this thread:

to me it looks like I need to edit this section of the .env file

## Domain settings
## The domain must match the address from where you access the server
## It's recommended to configure this value, otherwise certain functionality might not work,
## like attachment downloads, email links and U2F.
## For U2F to work, the server must use HTTPS, you can use Let's Encrypt for free certs
# DOMAIN=https://bw.domain.tld:8443


before I mess something up, has anyone had to do this or is there another fix for the attachments I’m missing?

Interesting, never used that feature.
Confirmed, you cannot download attachment on mobile.
I will get back to you after checking what exactly does not work and if we can fix it.

1 Like

You were right, fixed, can you update?

perfect, thanks for the quick fix.

1 Like